Hello Guest

Support for PHP version 7?

  • 2 Replies
  • 265 Views
Support for PHP version 7?
« on: December 25, 2018, 07:44:13 PM »
Hi
I have been using XT-CMS on PHP v5 for a while and recently received an email from my ISP telling me that this version would shortly become unsupported and strongly recommending that I should update to V7.2. I proceeded to do this, assuming (wrongly) that developers of such widely used software would take care to make it backward-compatible, and now I find that my website has completely stopped working!
I guess that I could revert to v5.x, but I would prefer to use a fully supported version of PHP. Your FAQ page says "PHP 7 is currently not yet supported but this will come in the future." - is this likely to happen soon, or is it a big piece of development work that doesn't warrant the effort?
Many thanks and all the best for 2019
Peter

*

xtom

  • *****
  • 184
    • View Profile
    • XT CMS
Re: Support for PHP version 7?
« Reply #1 on: January 04, 2019, 06:51:26 PM »
PHP7 will be supported in the next release of the CMS which should be out (touch wood) some time in the first half of this year. Hopefully sooner rather than later in that time. It's already up and running on PHP7 so no significant development work in this area is required. For now my advice is to stick with PHP5.6 if possible until the new version is out. Sorry about the wait and happy new year to you too.

*

xtom

  • *****
  • 184
    • View Profile
    • XT CMS
Re: Support for PHP version 7?
« Reply #2 on: August 04, 2019, 11:20:45 PM »
The latest release version of the CMS now supports PHP7.