Hello Guest

Odd Issue with dynamic content

  • 6 Replies
  • 3094 Views
Odd Issue with dynamic content
« on: November 11, 2013, 05:49:14 PM »
on my website I am working on the last paragraph is being cut off, wether i do a short or a long one the last paragraph gets cut off for some reason any ideas?

www.totaltech.biz

Re: Odd Issue with dynamic content
« Reply #1 on: November 11, 2013, 06:02:52 PM »
OK After some troubleshooting, i can figure that the content is there it is just under the footer section, the page content is expanding the background but the footer is going on top of the buttom amount of the content, would something in the page background layer need changed to make this work properly?

*

xtom

  • *****
  • 184
    • View Profile
    • XT CMS
Re: Odd Issue with dynamic content
« Reply #2 on: November 11, 2013, 06:23:39 PM »
It looks like you haven't named the footer background object. In xara apply the name "footerBackground" to your footer background object and see if this fixes the problem.

Re: Odd Issue with dynamic content
« Reply #3 on: November 11, 2013, 06:33:35 PM »
It is named, only thing i can tell is it is a repeating group, would this be a problem?

*

xtom

  • *****
  • 184
    • View Profile
    • XT CMS
Re: Odd Issue with dynamic content
« Reply #4 on: November 11, 2013, 07:02:22 PM »
Yes it's probably that, only one name will be exported as the ID for the image/div in the exported html so whatever is the first name applied will be the one exported into the html source.

Try stop updating the object so it's not repeating and remove any existing names and then add the name "footerBackground" - You should be able to make it repeating again after the "footerBackground" name is added.

Re: Odd Issue with dynamic content
« Reply #5 on: November 11, 2013, 07:24:57 PM »
Awsome! Thanks for the help, I do believe the problem was that I had a group down there, even after turning off repeating, still didn't work, then I put everything back to the way it was and just put a plain box with same color as background, then set that to be my "footerBackground" and boom! worked like a charm.

Thanks again.

*

xtom

  • *****
  • 184
    • View Profile
    • XT CMS
Re: Odd Issue with dynamic content
« Reply #6 on: November 11, 2013, 07:52:46 PM »
It should work with grouped objects too so long as the name is applied to the group and the group is on the footer layer but anyway glad you got it working :)