Hello Guest

Cannot Install the script, plz help :(

  • 6 Replies
  • 9835 Views
Cannot Install the script, plz help :(
« on: October 19, 2011, 05:04:37 PM »
hi admin,

why i cannot install the script?

the messages said :

PHP script /home/iddollar/public_html/scripts/cms_front.php is protected by SourceGuardian and requires the SourceGuardian loader ixed.5.2.lin. The SourceGuardian loader has not been installed, or is not installed correctly. Please find the required loader within SourceGuardian installation directory or visit the SourceGuardian php encoder site to download it.

need u're help..

my website http://id-dollar.com

*

xtom

  • *****
  • 184
    • View Profile
    • XT CMS
Re: Cannot Install the script, plz help :(
« Reply #1 on: October 20, 2011, 06:09:23 PM »
For php version 5.2 and above the required loader file "ixed.5.2.lin" needs to be copied from the cms/ixed directory into the php extension_dir. If dynamic loading is enabled which is usually the case then this is all that is required, if it's not enabled the loader will also need to specified in the php.ini file by adding a line pointing to the file eg. extension=ixed.5.2.lin

If you are on shared hosting and do not have access to the extension_dir on your server you will need to contact your host to do this for you. Alternatively you might be able to try switching to a php 4 version, some hosts allow you to switch between from php 5 to php 4 using the control panel or a htaccess file.

With php 4 it loads the file automatically from the cms/ixed directory but with php 5.2 it's a little more awkward as it needs to be copied into the php extension_dir

Re: Cannot Install the script, plz help :(
« Reply #2 on: October 25, 2012, 06:59:45 PM »
I'm also trying to install the trial and getting the sourceguardian problem when trying to configure the admin. I contacted my shared hosting provider who came up with the following:

"To be honest, I'm not sure that this would be compatible with our servers. It can get to the file successfully, the error that's being reported though, seems to suggest a problem with the file it is trying to load:

Warning: dl() [function.dl]: Unable to load dynamic library '/usr/lib64/php4//../../../home/sites/*mysite*/public_html/cms/ixed/ixed.4.4.lin' - /usr/lib64/php4//../../../home/sites/*mysite*/public_html/cms/ixed/ixed.4.4.lin: wrong ELF class: ELFCLASS32 in /home/sites/*mysite*/public_html/cms/scripts/default.php on line 2

Are you able to see if there is an updated version of ixed.4.4.lin or contact the developers of the script to see what they suggest?"

*

xtom

  • *****
  • 184
    • View Profile
    • XT CMS
Re: Cannot Install the script, plz help :(
« Reply #3 on: October 26, 2012, 12:05:38 PM »
The best way to solve a sourceguardian error is to use the loader assistant on the their website -> http://www.sourceguardian.com/loaders/download.php - You need to upload a simple phpinfo.php file to your server which will output the php settings of your server. When you give the loader assistant that info it will let you know if it is possible and what is required to get sourceguardian up an running, it should also give you a link to download the exact loader file required although the loader files included in the install package usually work fine for most setups.


phpinfo.php should have the following code to output the php settings on your server
Code: [Select]
<?php

phpinfo
();

?>


Re: Cannot Install the script, plz help :(
« Reply #4 on: October 26, 2012, 12:45:55 PM »
Thanks, that got me into admin and then ultimately the configuration screen. However when I saved the settings for "mytheme" I got the following errors:


Warning: sort() expects parameter 1 to be array, null given in /home/sites/*mysite*/public_html/cms/admin/includes/config.php on line 251

Warning: Invalid argument supplied for foreach() in /home/sites/*mysite*/public_html/cms/admin/includes/config.php on line 253

Warning: Invalid argument supplied for foreach() in /home/sites/*mysite*//public_html/cms/admin/includes/config.php on line 352

Warning: Invalid argument supplied for foreach() in /home/sites/*mysite*/public_html/cms/admin/includes/config.php on line 424

And when trying to view the site, the following is displayed:

Warning: main(cms/scripts/cms_front.php) [function.main]: failed to open stream: No such file or directory in /home/sites/*mysite*/public_html/cms/index.php on line 1

Fatal error: main() [function.require]: Failed opening required 'cms/scripts/cms_front.php' (include_path='.:/usr/share/pear') in /home/sites/*mysite*/public_html/cms/index.php on line 1

*

xtom

  • *****
  • 184
    • View Profile
    • XT CMS
Re: Cannot Install the script, plz help :(
« Reply #5 on: October 26, 2012, 03:44:59 PM »
I think those error messages might be a result of an empty mytheme folder? It looks like it is trying to list the template files in the theme folder but there are none present so it's spitting out some error messages. It's nothing major that will affect anything but I will get this fixed for the next version. Another way to setup a new theme is to copy the existing default theme folder and rename it mytheme or whatever, that way you have the basic files needed to display pages etc. and can then edit or overwrite them with your own.

The error message when trying to view the website is from it trying to locate the main cms_front.php - It looks like you might have changed this but are still accessing the index.php in the cms folder.

So if you are using the index.php in cms folder to display the front end it should be...

Code: [Select]
<?php require_once("scripts/cms_front.php"?>
This above should be how it is set on a fresh install so that it works out of the box.

And if you wanted to run the front end from the root of your website you would need to have this index.php in your websites root folder and you would change the pathof the file to...

Code: [Select]
<?php require_once("cms/scripts/cms_front.php"?>
Bear in mind the cms url in configuration settings should also be set to where the main index.php you are using accessing is located.

Re: Cannot Install the script, plz help :(
« Reply #6 on: October 26, 2012, 05:30:39 PM »
You're absolutely correct. I had exported the site but forgotten to upload it.

It's working fine now.