Hello Guest

Switching CMS from http to https mode

  • 0 Replies
  • 198 Views
*

xtom

  • *****
  • 184
    • View Profile
    • XT CMS
Switching CMS from http to https mode
« on: January 03, 2019, 11:01:32 AM »
The CMS is set to use http:// by default on a fresh install but if you are using https:// on your website you will need to make the following changes for the CMS to work properly.

For the latest version 2.x do the the following:

In scripts/config.php manually set the cms_protocol to use either http:// or https://  - If you have a secure cert setup and active on your site set it to https://.

If it's a fresh install of the CMS then changing cms_protocol is all you will need to do. If you are changing cms_protocol on a site that already has pages and content you should do the following steps to reset the cache, page templates and update any existing links in content areas.

1. Go to Advanced -> Maintenance in the admin menu
2. Click Reset Page Templates
3. Click Reset Cache
4. Click Update Links

If you are using the sitemap feature you should also click Update Sitemap.

These steps should update existing pages, links and file references to the new protocol.



For older versions 1.9.x you will need to do the following

In scripts/config.php manually set the cms_root_url to use https:// in the address and make sure the line is uncommented by removing the two slashes at the stat of the line - see example below..

Code: [Select]
define('cms_root_url','https://mydomain.com/cms/');
In the advanced configuration section of admin area make sure CMS URL and Website URL are also set with https in the addresses.
« Last Edit: August 05, 2019, 07:09:10 PM by xtom »