Hello Guest

Installed, but receiving error messages from server

  • 1 Replies
  • 1767 Views
*

STS

  • *
  • 5
    • View Profile
Installed, but receiving error messages from server
« on: December 09, 2016, 04:03:08 PM »
I have been working with XT-CMS on my localhost successfully, so the next step is to install it on my host's server. I do want to offer the CMS to my clients who have expressed desires to be able to modify portions of their website without my interaction.

I was able to install on the remote server and got to the admin login page, but with the following errors:
___________

Warning: ini_set() has been disabled for security reasons in /home/smalltow/public_html/cms/scripts/default.php on line 0

Warning: Cannot modify header information - headers already sent by (output started at /home/smalltow/public_html/cms/scripts/default.php:0) in /home/smalltow/public_html/cms//scripts/functions.php on line 0
___________

I've sent a  note to my host support guy, but perhaps you are a better source of assistance. Any help will be appreciated. Thanks.

Addendum 1: I heard from my host support guy and he is not familiar with the error messages and is only vaguely aware of ionCube. He won't be much help.

Addendum 2: I also tried to install on a GoDaddy server and had no problems.

Addendum 3: I contacted my server host and he provided the following information:
"Here is the recommended setting for ini_set and what to do about it
You should consider adding ini_set to the disable_functions in the PHP configuration as this setting allows PHP scripts to override global security and performance settings for PHP scripts. Adding ini_set can break PHP scripts and commenting out any use of ini_set in such scripts is advised".

Is there any way I can do that?

« Last Edit: December 10, 2016, 06:35:58 PM by STS »

*

xtom

  • *****
  • 184
    • View Profile
    • XT CMS
Re: Installed, but receiving error messages from server
« Reply #1 on: January 10, 2017, 10:03:04 AM »
Quote
Warning: ini_set() has been disabled for security reasons in /home/smalltow/public_html/cms/scripts/default.php on line 0

This error is because the host has disabled use of the ini_set() PHP function. I've not encountered a host that has disabled this function before but they have given you the instructions on how to enable it by commenting it out/removing it from  of the disable_functions in the PHP configuration file.