XT-CMS Forum

Themes & Page Design => XT-CMS + Xara => Topic started by: xtom on June 11, 2022, 01:11:12 AM

Title: Missing currency symbol (Xara font export)
Post by: xtom on June 11, 2022, 01:11:12 AM
Just a quick note on this for future reference.

Xara seems to sometimes omit certain glyphs from exported font files when they are not actually used in the document's text.
For example when I set the CSS for the CMS to use the same exported font from Xara the Euro symbol € was not showing on dynamic content / product prices.

By adding a Euro symbol on some text in the Xara document it then exported the font with the glyph included and it then displayed on the dynamic content too.
Title: Missing currency symbol (Xara font export)
Post by: xtom on July 25, 2022, 09:12:08 PM
In addition to the above post note that some fonts may also use ligatures for certain character combinations. For example "fi" in the word "Confirm" if the ligature is not in the exported font you may see missing characters eg. "Con rm" where the "fi" is missing. In this situation you can disable ligatures on particular elements and classes by setting font-variant-ligatures: none; or alternatively font-feature-settings: "liga" 0;

Reference links:
https://developer.mozilla.org/en-US/docs/Web/CSS/font-variant-ligatures
https://developer.mozilla.org/en-US/docs/Web/CSS/font-feature-settings

Interestingly this seems to only affect button element text in Firefox browser and it does not seem to happen at all in Edge browser or Chrome. So it looks like the default browser styles in Firefox are set to use ligatures on buttons and the Xara exported CSS does not override the ligature CSS for button element text.